$re = '/( )( )*([^ ])/';
$str = 'abc def ghi xyz';
$subst = "$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;