# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/url\s*\(\s*[\'"]?(?!(((?:https?:)?\\/\\/)|(?:data\:?:)))([^\'"\)]+)[\'"]?\s*\)/url("\/themes\/default\/css\/$3")/g;t' <<< "#TEST {
background:url(test.jpg);
background:url( 'test.jpg' );
background:url(\"test.jpg\" );
background:url(http://example.com/test.jpg);
background:url('https://example.com/test.jpg');
background:url(\"http://example.com/test.jpg\");
background:url( '//example.com/test.jpg' );
background:url( \"//example.com/test.jpg\" );
background:url(//example.com/test.jpg);
}"