using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\s*\(\s*[\'""]?(?!(((?:https?:)?\/\/)|(?:data\:?:)))([^\'""\)]+)[\'""]?\s*\)";
string substitution = @"url(""/themes/default/css/$3"")";
string input = @"#TEST {
background:url(test.jpg);
background:url( 'test.jpg' );
background:url(""test.jpg"" );
background:url(http://example.com/test.jpg);
background:url('https://example.com/test.jpg');
background:url(""http://example.com/test.jpg"");
background:url( '//example.com/test.jpg' );
background:url( ""//example.com/test.jpg"" );
background:url(//example.com/test.jpg);
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}