use strict;
my $str = '#TEST {
background:url(test.jpg);
background:url( \'test.jpg\' );
background:url("test.jpg" );
background:url(http://example.com/test.jpg);
background:url(\'https://example.com/test.jpg\');
background:url("http://example.com/test.jpg");
background:url( \'//example.com/test.jpg\' );
background:url( "//example.com/test.jpg" );
background:url(//example.com/test.jpg);
}';
my $regex = qr/url\s*\(\s*[\'"]?(?!(((?:https?:)?\/\/)|(?:data\:?:)))([^\'"\)]+)[\'"]?\s*\)/p;
my $subst = 'url("/themes/default/css/$3")';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";