# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"url\s*\(\s*[\'\"]?(?!(((?:https?:)?\/\/)|(?:data\:?:)))([^\'\"\)]+)[\'\"]?\s*\)"
test_str = ("#TEST {\n"
" background:url(test.jpg);\n"
" background:url( 'test.jpg' );\n"
" background:url(\"test.jpg\" );\n"
" background:url(http://example.com/test.jpg);\n"
" background:url('https://example.com/test.jpg');\n"
" background:url(\"http://example.com/test.jpg\");\n"
" background:url( '//example.com/test.jpg' );\n"
" background:url( \"//example.com/test.jpg\" );\n"
" background:url(//example.com/test.jpg);\n"
"}")
subst = "url(\"/themes/default/css/$3\")"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.