#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "url\s*\(\s*[\'"]?(?!(((?:https?:)?\/\/)|(?:data\:?:)))([^\'"\)]+)[\'"]?\s*\)"
Local $sString = "#TEST {" & @CRLF & _
" background:url(test.jpg);" & @CRLF & _
" background:url( 'test.jpg' );" & @CRLF & _
" background:url("test.jpg" );" & @CRLF & _
" background:url(http://example.com/test.jpg);" & @CRLF & _
" background:url('https://example.com/test.jpg');" & @CRLF & _
" background:url("http://example.com/test.jpg");" & @CRLF & _
" background:url( '//example.com/test.jpg' );" & @CRLF & _
" background:url( "//example.com/test.jpg" );" & @CRLF & _
" background:url(//example.com/test.jpg);" & @CRLF & _
"}"
Local $sSubst = "url("/themes/default/css/$3")"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)