import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\s*\\(\\s*[\\'\"]?(?!(((?:https?:)?\\/\\/)|(?:data\\:?:)))([^\\'\"\\)]+)[\\'\"]?\\s*\\)";
final String string = "#TEST {\n"
+ " background:url(test.jpg);\n"
+ " background:url( 'test.jpg' );\n"
+ " background:url(\"test.jpg\" );\n"
+ " background:url(http://example.com/test.jpg);\n"
+ " background:url('https://example.com/test.jpg');\n"
+ " background:url(\"http://example.com/test.jpg\");\n"
+ " background:url( '//example.com/test.jpg' );\n"
+ " background:url( \"//example.com/test.jpg\" );\n"
+ " background:url(//example.com/test.jpg);\n"
+ "}";
final String subst = "url(\"/themes/default/css/$3\")";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}