using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""listing-img-container media-cover text-center"">[\s\S]*?src=""([^""]+?\.jpg)";
string input = @"<div class=""panel-image listing-img"">
<a href=""/rooms/854260?s=BD20"" class=""media-photo media-cover"">
<div class=""listing-img-container media-cover text-center"">
<img itemprop=""image"" data-current=""0"" src=""https://a2.muscache.com/ic/pictures/19208233/4d8e6c0d_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70""
class=""img-responsive-height"" alt=""Cozy room - Prague centre Old Town"" data-urls=""[output-format=jpg&output-quality=70", "https://a1.mu "ut-format=jpg&output-quality=70"]"">
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}