package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div class="listing-img-container media-cover text-center">[\s\S]*?src="([^"]+?\.jpg)`)
var str = `<div class="panel-image listing-img">
<a href="/rooms/854260?s=BD20" class="media-photo media-cover">
<div class="listing-img-container media-cover text-center">
<img itemprop="image" data-current="0" src="https://a2.muscache.com/ic/pictures/19208233/4d8e6c0d_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70"
class="img-responsive-height" alt="Cozy room - Prague centre Old Town" data-urls="[output-format=jpg&output-quality=70", "https://a1.mu "ut-format=jpg&output-quality=70"]">
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}