use strict;
my $str = '<div class="panel-image listing-img">
<a href="/rooms/854260?s=BD20" class="media-photo media-cover">
<div class="listing-img-container media-cover text-center">
<img itemprop="image" data-current="0" src="https://a2.muscache.com/ic/pictures/19208233/4d8e6c0d_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70"
class="img-responsive-height" alt="Cozy room - Prague centre Old Town" data-urls="[output-format=jpg&output-quality=70", "https://a1.mu "ut-format=jpg&output-quality=70"]">
</div>';
my $regex = qr/<div class="listing-img-container media-cover text-center">[\s\S]*?src="([^"]+?\.jpg)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}