import re
regex = re.compile(r"<div class=\"listing-img-container media-cover text-center\">[\s\S]*?src=\"([^\"]+?\.jpg)")
test_str = ("<div class=\"panel-image listing-img\">\n"
" <a href=\"/rooms/854260?s=BD20\" class=\"media-photo media-cover\">\n"
" <div class=\"listing-img-container media-cover text-center\">\n"
" <img itemprop=\"image\" data-current=\"0\" src=\"https://a2.muscache.com/ic/pictures/19208233/4d8e6c0d_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70\"\n"
" class=\"img-responsive-height\" alt=\"Cozy room - Prague centre Old Town\" data-urls=\"[output-format=jpg&output-quality=70", "https://a1.mu "ut-format=jpg&output-quality=70"]\">\n"
" </div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")