import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"listing-img-container media-cover text-center\">[\\s\\S]*?src=\"([^\"]+?\\.jpg)";
final String string = "<div class=\"panel-image listing-img\">\n"
+ " <a href=\"/rooms/854260?s=BD20\" class=\"media-photo media-cover\">\n"
+ " <div class=\"listing-img-container media-cover text-center\">\n"
+ " <img itemprop=\"image\" data-current=\"0\" src=\"https://a2.muscache.com/ic/pictures/19208233/4d8e6c0d_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70\"\n"
+ " class=\"img-responsive-height\" alt=\"Cozy room - Prague centre Old Town\" data-urls=\"[output-format=jpg&output-quality=70", "https://a1.mu "ut-format=jpg&output-quality=70"]\">\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}