const regex = new RegExp('<div class="listing-img-container media-cover text-center">[\\s\\S]*?src="([^"]+?\\.jpg)', 'g')
const str = `<div class="panel-image listing-img">
<a href="/rooms/854260?s=BD20" class="media-photo media-cover">
<div class="listing-img-container media-cover text-center">
<img itemprop="image" data-current="0" src="https://a2.muscache.com/ic/pictures/19208233/4d8e6c0d_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70"
class="img-responsive-height" alt="Cozy room - Prague centre Old Town" data-urls="[output-format=jpg&output-quality=70", "https://a1.mu "ut-format=jpg&output-quality=70"]">
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}