#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)sku-(\d+)sku-\1"
Local $sString = "<sku>V31L-CPFIJK-11077</sku>" & @CRLF & _
"<image1>https://testtest.pl/getled/sku-11077sku-11077.jpg</image1> " & @CRLF & _
"<image2>https://testtest.pl/getled/sku-11077sku-11077,1.jpg</image2>" & @CRLF & _
"" & @CRLF & _
"<sku>V31L-CPFIJK-11033</sku>" & @CRLF & _
"<image1>https://testtest.pl/getled/sku-11033sku-11033.jpg</image1> " & @CRLF & _
"<image2>https://testtest.pl/getled/sku-11033sku-11033,1.jpg</image2>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)