import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "sku-(\\d+)sku-\\1";
final String string = "<sku>V31L-CPFIJK-11077</sku>\n"
+ "<image1>https://testtest.pl/getled/sku-11077sku-11077.jpg</image1> \n"
+ "<image2>https://testtest.pl/getled/sku-11077sku-11077,1.jpg</image2>\n\n"
+ "<sku>V31L-CPFIJK-11033</sku>\n"
+ "<image1>https://testtest.pl/getled/sku-11033sku-11033.jpg</image1> \n"
+ "<image2>https://testtest.pl/getled/sku-11033sku-11033,1.jpg</image2>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}