# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"sku-(\d+)sku-\1"
test_str = ("<sku>V31L-CPFIJK-11077</sku>\n"
"<image1>https://testtest.pl/getled/sku-11077sku-11077.jpg</image1> \n"
"<image2>https://testtest.pl/getled/sku-11077sku-11077,1.jpg</image2>\n\n"
"<sku>V31L-CPFIJK-11033</sku>\n"
"<image1>https://testtest.pl/getled/sku-11033sku-11033.jpg</image1> \n"
"<image2>https://testtest.pl/getled/sku-11033sku-11033,1.jpg</image2>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.