using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sku-(\d+)sku-\1";
string substitution = @"$1";
string input = @"<sku>V31L-CPFIJK-11077</sku>
<image1>https://testtest.pl/getled/sku-11077sku-11077.jpg</image1>
<image2>https://testtest.pl/getled/sku-11077sku-11077,1.jpg</image2>
<sku>V31L-CPFIJK-11033</sku>
<image1>https://testtest.pl/getled/sku-11033sku-11033.jpg</image1>
<image2>https://testtest.pl/getled/sku-11033sku-11033,1.jpg</image2>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}