const regex = /sku-(\d+)sku-\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('sku-(\\d+)sku-\\1', 'gm')
const str = `<sku>V31L-CPFIJK-11077</sku>
<image1>https://testtest.pl/getled/sku-11077sku-11077.jpg</image1>
<image2>https://testtest.pl/getled/sku-11077sku-11077,1.jpg</image2>
<sku>V31L-CPFIJK-11033</sku>
<image1>https://testtest.pl/getled/sku-11033sku-11033.jpg</image1>
<image2>https://testtest.pl/getled/sku-11033sku-11033,1.jpg</image2>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);