import Foundation
let pattern = #"sku-(\d+)sku-\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<sku>V31L-CPFIJK-11077</sku>
<image1>https://testtest.pl/getled/sku-11077sku-11077.jpg</image1>
<image2>https://testtest.pl/getled/sku-11077sku-11077,1.jpg</image2>
<sku>V31L-CPFIJK-11033</sku>
<image1>https://testtest.pl/getled/sku-11033sku-11033.jpg</image1>
<image2>https://testtest.pl/getled/sku-11033sku-11033,1.jpg</image2>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)