#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)talkdev.co.uk\/.*billsandpayments.*"
Local $sString = "talkdev.co.uk/asdasdasdasd/billsandpayments/asdasdasd" & @CRLF & _
"https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339" & @CRLF & _
"" & @CRLF & _
"talkdev.co.uk/asd/billsandpayments/asdasdasd" & @CRLF & _
"" & @CRLF & _
"talkdev.co.uk/billsandpayments" & @CRLF & _
"" & @CRLF & _
"https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")