const regex = /talkdev.co.uk\/.*billsandpayments.*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('talkdev.co.uk\\\/.*billsandpayments.*', 'gmi')
const str = `talkdev.co.uk/asdasdasdasd/billsandpayments/asdasdasd
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339
talkdev.co.uk/asd/billsandpayments/asdasdasd
talkdev.co.uk/billsandpayments
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}