re = /talkdev.co.uk\/.*billsandpayments.*/mi
str = 'talkdev.co.uk/asdasdasdasd/billsandpayments/asdasdasd
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339
talkdev.co.uk/asd/billsandpayments/asdasdasd
talkdev.co.uk/billsandpayments
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end