use strict;
my $str = 'talkdev.co.uk/asdasdasdasd/billsandpayments/asdasdasd
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339
talkdev.co.uk/asd/billsandpayments/asdasdasd
talkdev.co.uk/billsandpayments
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339';
my $regex = qr/talkdev.co.uk\/.*billsandpayments.*/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}