import re
regex = re.compile(r"talkdev.co.uk\/.*billsandpayments.*", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("talkdev.co.uk/asdasdasdasd/billsandpayments/asdasdasd\n"
"https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339\n\n"
"talkdev.co.uk/asd/billsandpayments/asdasdasd\n\n"
"talkdev.co.uk/billsandpayments\n\n"
"https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")