using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"talkdev.co.uk\/.*billsandpayments.*";
string input = @"talkdev.co.uk/asdasdasdasd/billsandpayments/asdasdasd
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339
talkdev.co.uk/asd/billsandpayments/asdasdasd
talkdev.co.uk/billsandpayments
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}