// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)talkdev.co.uk\/.*billsandpayments.*").unwrap();
let string = "talkdev.co.uk/asdasdasdasd/billsandpayments/asdasdasd
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339
talkdev.co.uk/asd/billsandpayments/asdasdasd
talkdev.co.uk/billsandpayments
https://tagmanager.google.com/#/container/accounts/71467998/containers/2049339";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}