using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0[1-9]|[1-2][0-9]|3[0-1])\/(0[1-9]|1[0-2])\/(\d{4})$";
string substitution = @"";
string input = @"13/07/1993
01/01/1993
12/12/1955
31/12/1999
1/12/1999
31/12/19992
32/13/1955
42/11/1955
01/12/2000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}