use strict;
my $str = '13/07/1993
01/01/1993
12/12/1955
31/12/1999
1/12/1999
31/12/19992
32/13/1955
42/11/1955
01/12/2000';
my $regex = qr/^(0[1-9]|[1-2][0-9]|3[0-1])\/(0[1-9]|1[0-2])\/(\d{4})$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";