import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0[1-9]|[1-2][0-9]|3[0-1])\\/(0[1-9]|1[0-2])\\/(\\d{4})$";
final String string = "13/07/1993\n"
+ "01/01/1993\n"
+ "12/12/1955\n"
+ "31/12/1999\n"
+ "1/12/1999\n"
+ "31/12/19992\n"
+ "32/13/1955\n"
+ "42/11/1955\n"
+ "01/12/2000";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}