// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0[1-9]|[1-2][0-9]|3[0-1])\/(0[1-9]|1[0-2])\/(\d{4})$").unwrap();
let string = "13/07/1993
01/01/1993
12/12/1955
31/12/1999
1/12/1999
31/12/19992
32/13/1955
42/11/1955
01/12/2000";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}