# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0[1-9]|[1-2][0-9]|3[0-1])\/(0[1-9]|1[0-2])\/(\d{4})$"
test_str = ("13/07/1993\n"
"01/01/1993\n"
"12/12/1955\n"
"31/12/1999\n"
"1/12/1999\n"
"31/12/19992\n"
"32/13/1955\n"
"42/11/1955\n"
"01/12/2000")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.