# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{4}(.\d{2}){2}(\s|T)(\d{2}.){2}\d{2}//g;t' <<< "2015-09-18 07:41:10.878357
2015-09-18T07:41:10.878357
2015/09/18T07:41:10.878357"