#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\d{4}(.\d{2}){2}(\s|T)(\d{2}.){2}\d{2}"
Local $sString = "2015-09-18 07:41:10.878357" & @CRLF & _
"2015-09-18T07:41:10.878357" & @CRLF & _
"2015/09/18T07:41:10.878357"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)