re = /\d{4}(.\d{2}){2}(\s|T)(\d{2}.){2}\d{2}/
str = '2015-09-18 07:41:10.878357
2015-09-18T07:41:10.878357
2015/09/18T07:41:10.878357'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result