import re
regex = re.compile(r"\d{4}(.\d{2}){2}(\s|T)(\d{2}.){2}\d{2}")
test_str = ("2015-09-18 07:41:10.878357\n"
"2015-09-18T07:41:10.878357\n"
"2015/09/18T07:41:10.878357")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)