using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{4}(.\d{2}){2}(\s|T)(\d{2}.){2}\d{2}";
string substitution = @"";
string input = @"2015-09-18 07:41:10.878357
2015-09-18T07:41:10.878357
2015/09/18T07:41:10.878357";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}