# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<autorpodpis>([^;,<\n\r]*?)\s*[;,<\n\r]/\1/g;t' <<< "wydanie z dnia 21/09/2 <autorpodpis>WOJCIECH ZAŁUSKA </autorpodpis>Miller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA,</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA </aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA, PAP</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA; PAP</aMiller idzie z Wrzodakiem
"