package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<autorpodpis>([^;,<\n\r]*?)\s*[;,<\n\r]`)
var str = `wydanie z dnia 21/09/2 <autorpodpis>WOJCIECH ZAŁUSKA </autorpodpis>Miller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA,</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA </aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA, PAP</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA; PAP</aMiller idzie z Wrzodakiem
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}