// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<autorpodpis>([^;,<\n\r]*?)\s*[;,<\n\r]").unwrap();
let string = "wydanie z dnia 21/09/2 <autorpodpis>WOJCIECH ZAŁUSKA </autorpodpis>Miller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA,</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA </aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA, PAP</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA; PAP</aMiller idzie z Wrzodakiem
";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}