import Foundation
let pattern = #"<autorpodpis>([^;,<\n\r]*?)\s*[;,<\n\r]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
wydanie z dnia 21/09/2 <autorpodpis>WOJCIECH ZAŁUSKA </autorpodpis>Miller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA,</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA </aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA, PAP</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA; PAP</aMiller idzie z Wrzodakiem
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)