use strict;
my $str = 'wydanie z dnia 21/09/2 <autorpodpis>WOJCIECH ZAŁUSKA </autorpodpis>Miller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA,</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA </aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA, PAP</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA; PAP</aMiller idzie z Wrzodakiem
';
my $regex = qr/<autorpodpis>([^;,<\n\r]*?)\s*[;,<\n\r]/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";