$re = '/<autorpodpis>([^;,<\n\r]*?)\s*[;,<\n\r]/';
$str = 'wydanie z dnia 21/09/2 <autorpodpis>WOJCIECH ZAŁUSKA </autorpodpis>Miller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA,</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA </aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA, PAP</aMiller idzie z Wrzodakiem
<autorpodpis>WOJCIECH ZAŁUSKA; PAP</aMiller idzie z Wrzodakiem
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;