#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms).*begin|end.*|[^e]*?\b([A-Z]{2,})\b"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. " & @CRLF & _
"NOT MATCHED in HERE Vestibulum vehicula arcu cursus justo luctus gravida. Praesent elefur dictum sollicitudin. " & @CRLF & _
"begin" & @CRLF & _
"Nullam mi justo, pulvinar sit amet leo sed, commodo malesuada nulla. " & @CRLF & _
"but MATCHED HERE Donec lobortis arcu eget turpis commodo, sed interdum leo OK elefur. " & @CRLF & _
"end" & @CRLF & _
"NOT MATCHED HERE " & @CRLF & _
"Cras venenatis felis vel nisi elementum varius. " & @CRLF & _
"Proin TEST sed magna sed erat consequat pretium eu sit amet nibh."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")