// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms).*begin|end.*|[^e]*?\b([A-Z]{2,})\b").unwrap();
let string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit.
NOT MATCHED in HERE Vestibulum vehicula arcu cursus justo luctus gravida. Praesent elefur dictum sollicitudin.
begin
Nullam mi justo, pulvinar sit amet leo sed, commodo malesuada nulla.
but MATCHED HERE Donec lobortis arcu eget turpis commodo, sed interdum leo OK elefur.
end
NOT MATCHED HERE
Cras venenatis felis vel nisi elementum varius.
Proin TEST sed magna sed erat consequat pretium eu sit amet nibh.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}