import re
regex = re.compile(r".*begin|end.*|[^e]*?\b([A-Z]{2,})\b", flags=re.MULTILINE | re.DOTALL)
test_str = ("Lorem ipsum dolor sit amet, consectetur adipiscing elit. \n"
"NOT MATCHED in HERE Vestibulum vehicula arcu cursus justo luctus gravida. Praesent elefur dictum sollicitudin. \n"
"begin\n"
"Nullam mi justo, pulvinar sit amet leo sed, commodo malesuada nulla. \n"
"but MATCHED HERE Donec lobortis arcu eget turpis commodo, sed interdum leo OK elefur. \n"
"end\n"
"NOT MATCHED HERE \n"
"Cras venenatis felis vel nisi elementum varius. \n"
"Proin TEST sed magna sed erat consequat pretium eu sit amet nibh.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")