using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*begin|end.*|[^e]*?\b([A-Z]{2,})\b";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit.
NOT MATCHED in HERE Vestibulum vehicula arcu cursus justo luctus gravida. Praesent elefur dictum sollicitudin.
begin
Nullam mi justo, pulvinar sit amet leo sed, commodo malesuada nulla.
but MATCHED HERE Donec lobortis arcu eget turpis commodo, sed interdum leo OK elefur.
end
NOT MATCHED HERE
Cras venenatis felis vel nisi elementum varius.
Proin TEST sed magna sed erat consequat pretium eu sit amet nibh.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}