package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms).*begin|end.*|[^e]*?\b([A-Z]{2,})\b`)
var str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit.
NOT MATCHED in HERE Vestibulum vehicula arcu cursus justo luctus gravida. Praesent elefur dictum sollicitudin.
begin
Nullam mi justo, pulvinar sit amet leo sed, commodo malesuada nulla.
but MATCHED HERE Donec lobortis arcu eget turpis commodo, sed interdum leo OK elefur.
end
NOT MATCHED HERE
Cras venenatis felis vel nisi elementum varius.
Proin TEST sed magna sed erat consequat pretium eu sit amet nibh.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}