# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<coverpage><image l:href=\"#(.*?)\"\/><\/coverpage>//gi;t' <<< "<coverpage><image l:href=\"#cover.jpg\"/></coverpage>"