const regex = new RegExp('<coverpage><image l:href=\\"#(.*?)\\"/></coverpage>', 'gi')
const str = `<coverpage><image l:href="#cover.jpg"/></coverpage>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);