use strict;
my $str = '<coverpage><image l:href="#cover.jpg"/></coverpage>';
my $regex = qr/<coverpage><image l:href=\"#(.*?)\"/></coverpage>/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";